Jump to content
Sign in to follow this  
Adi Geo

Problema Facebook Open Graph (Og:type Si Og:url)

Recommended Posts

Buna ziua!

Imi cer scuze ca nu m-am prezentat si ca primul lucru pe care il fac este sa va cer suport in rezolvarea unei probleme, dar timpul meu este limitat.

Am un website pe care am instalat platforma WordPress si de cateva zile in momentul cand postez link-ul articolului pe facebook, imaginea de thumbnail, titlul si meta descrierea nu se afiseaza.

Cei de la firma de hosting au spus ca probabil se datoreaza schimbarilor pe care le-am facut temei. Am mai gasit pe Google ca pluginul SEO pe care il folosesc (WordPress Plugins by Yoast) poate interfera cu alte pluginuri.

Am schimbat tema, am oprit toate celelalte pluginuri dar problema persista. Acum am revenit la tema pe care o aveam (Ribbon, restilizata CSS/imagini de catre de mine) si am reintrodus plugin-urile, deoarece am constatat ca buba probabil este alta, dar care?

Acestea sunt informatiile furnizate mie de catre Facebook Object Debugger:

 

The 'og:type' property is required, but not present.

The 'og:url' property should be explicitly provided, even if a value can be inferred from other tags.

 

Nu am experienta cu protocolul Open Graph, deci mi-am cam prins urechile.

Mentionez si ca site-ul meu foloseste un certificat SSL Comodo Positive.

Cu permisiunea unui membru din staff am sa public link-ul. Nu doresc sa fac reclama, am doar nevoie de ajutor.

Sper ca am postat unde trebuie, dar in opinia mea Open Graph intra in categoria SEO. Daca m-am inselat, rog respectuos un membru al echipei dvs. sa mute acest topic.

 

Cu stima,

Adi Geo Cosmescu.

Share this post


Link to post
Share on other sites

O problema similara a fost discutata intre un utilizator obisnuit si autorul plugin-ului WP Facebook Open Graph Protocol aici: https://wordpress.org/support/topic/ogtype-property-is-required-but-not-present, si se pare ca problema era de la incarcarea greoaie a site-ului provocata in special de tema folosita.

 

De asemenea, vezi sa nu ai mai multe plugin-uri care sa creeze tag-uri og: https://wordpress.org/support/topic/ogtype-not-present-facebook

 

Configuratia plugin-ului este buna: https://wordpress.org/support/topic/i-cant-share-links-on-facebook?

Share this post


Link to post
Share on other sites

Dupa cum am spus, am incercat si cu o alta tema, una standard, oferita in pachetul de baza WP, nimic complicat, si totusi nu a functionat.

De asemenea am precizat si ca am dezactivat toate pluginurile cu exceptia celui de la Yoast pentru SEO si tot nu. L-am dezactivat si pe el, am ramas cu 0 pluginuri active dar aceeasi problema.

Cat despre configurarea pluginului, din cate stiu e ok. Am creat o aplicatie pe facebook in zona developers, am numit-o SEO, am folosit App ID-ul pentru pluginul Yoast. De asemenea am adaugat si in <head> urmatoarele:

<meta property="fb:app_id" content="1469179953373392">
<meta property="fb:admins" content="100002267596620"/>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '1469179953373392',
      xfbml      : true,
      version    : 'v2.3'
    });
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk/debug.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>

Tot nu gasesc problema.

Iti las un mesaj cu link-ul site-ului (desi il am si in profil).

Share this post


Link to post
Share on other sites

Pare configurat ok. Cred ca cel mai bine ar fi sa incerci deschiderea unui ticket aici: https://wordpress.org/support/forum/plugins-and-hacks

Creatorul plugin-ului te va putea ajuta mai mult decat o pot face eu.

Share this post


Link to post
Share on other sites

Dupa ce mi-am scotocit creierul si nu am gasit solutii m-am gandit ca poate cei de la server au probleme la certificatul SSL, iar facebook debugger mi-a confirmat teoria.
A fost si mai ciudat cand am constatat ca cei de la suport desi eu le vorbeam in limba romana si le indicam eroarea, nu intelegeau ce le zic.
Intr-un final le-am indicat sub forma unor print screen-uri (daca nu le desenezi nu inteleg...) si dupa ce au stat ceva timp sa rumege informatia mi-au spus ca intradevar era de la ei si au remediat situatia fara a se sinchisi sa isi ceara scuze.
Desi imi venea sa le precizez toate rudele de grad 1, m-am abtinut, le-am multumit si am incheiat discutia.

Va multumesc mult pnetru suportul acordat!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...